Loading ...

高低点与波动率ROC指标策略

Author: 扫地僧, Date: 2021-11-04 14:57:51
Tags: 商品期货 趋势 My语言

  • 策略名称:高低点与波动率ROC指标策略
  • 数据周期:15M等
  • 支持:商品期货
  • 官方网站:www.quantinfo.com

img
img

  • 主图: N周期最高价,公式:HH^^HHV(H,N); N周期最低价,公式:LL^^LLV(L,N);

  • 副图: ARC指标, 公式:ARC:SMA(RC,M,1);


(*backtest
start: 2018-03-03 00:00:00
end: 2018-03-31 00:00:00
period: 15m
exchanges: [{"eid":"Futures_CTP","currency":"FUTURES"}]
args: [["ContractType","rb888",126961]]
*)

HH^^HHV(H,N);
LL^^LLV(L,N);
MD:=(HH+LL)/2;

UP:=H>=HH;
DOWN:=L<=LL;

RC:=CLOSE/REF(CLOSE,M);
ARC:SMA(RC,M,1);

BARPOS>N AND BKVOL=0 AND H>=HH AND ARC>1,BPK;
BARPOS>N AND SKVOL=0 AND L<=LL AND ARC<1,SPK;

DOWN AND C>BKPRICE*(1+SLOSS*0.01),SP(BKVOL);
UP AND C<SKPRICE*(1-SLOSS*0.01),BP(SKVOL);

C<BKPRICE*(1-SLOSS*0.01),SP(BKVOL);
C>SKPRICE*(1+SLOSS*0.01),BP(SKVOL);
AUTOFILTER;

相关内容

更多内容